Sunday, March 13, 2016

Quick way to install RPMs for Oracle 12c installation

https://docs.oracle.com/database/121/LADBI/pre_install.htm#LADBI7534
 
Packages for Oracle Linux 7 and Red Hat Enterprise Linux 7
The following packages (or later versions) must be installed:

binutils-2.23.52.0.1-12.el7.x86_64 
compat-libcap1-1.10-3.el7.x86_64
compat-libstdc++-33-3.2.3-71.el7.i686 
compat-libstdc++-33-3.2.3-71.el7.x86_64
gcc-4.8.2-3.el7.x86_64 
gcc-c++-4.8.2-3.el7.x86_64 
glibc-2.17-36.el7.i686 
glibc-2.17-36.el7.x86_64 
glibc-devel-2.17-36.el7.i686 
glibc-devel-2.17-36.el7.x86_64 
ksh
libaio-0.3.109-9.el7.i686 
libaio-0.3.109-9.el7.x86_64 
libaio-devel-0.3.109-9.el7.i686 
libaio-devel-0.3.109-9.el7.x86_64 
libgcc-4.8.2-3.el7.i686 
libgcc-4.8.2-3.el7.x86_64 
libstdc++-4.8.2-3.el7.i686 
libstdc++-4.8.2-3.el7.x86_64 
libstdc++-devel-4.8.2-3.el7.i686 
libstdc++-devel-4.8.2-3.el7.x86_64 
libXi-1.7.2-1.el7.i686 
libXi-1.7.2-1.el7.x86_64 
libXtst-1.2.2-1.el7.i686 
libXtst-1.2.2-1.el7.x86_64 
make-3.82-19.el7.x86_64 
sysstat-10.1.5-1.el7.x86_64 
 
=======================================
 
yum install binutils.x86_64 \
compat-libcap1.x86_64 \
compat-libstdc++-33.i686  \
compat-libstdc++-33.x86_64 \
gcc.x86_64  \
gcc-c++.x86_64  \
glibc.i686  \
glibc.x86_64  \
glibc-devel.i686  \
glibc-devel.x86_64  \
ksh \
libaio.i686  \
libaio.x86_64  \
libaio-devel.i686  \
libaio-devel.x86_64  \
libgcc.i686  \
libgcc.x86_64  \
libstdc++.i686  \
libstdc++.x86_64  \
libstdc++-devel.i686  \
libstdc++-devel.x86_64  \
libXi.i686  \
libXi.x86_64  \
libXtst.i686  \
libXtst.x86_64  \
make.x86_64  \
sysstat.x86_64