Sunday, September 27, 2026

User-managed RMAN backup disabled by default?

For Oracle AI Database releases 19.30, 23.26, 26ai, and later releases, RMAN backups for Oracle AI Databases in Multicloud environments may fail with the following error:


ORA-19968 - Backup Not Allowed in This Setup

This is due to a backup restriction for Oracle AI Database in Multicloud which occurs if either of the following conditions is true:

  1. RMAN is used to back up directly to a customer-managed storage location such as Amazon S3 or Azure Blob Storage
  2. RMAN is used with a 3rd party solution to back up the Oracle Database

RMAN is not supported to back up directly to customer-managed storage with any of the above-mentioned cloud database services . 

RMAN backups using a 3rd party solution can be supported via an exception after applying a database patch. (Link to KB914310)

Source information:

 https://www.youtube.com/watch?v=mU-sqiXSMpU&t=1922s




No comments:

Post a Comment